Compatibility woocommerce products slider with WP 4.4?

Q&ACategory: PluginCompatibility woocommerce products slider with WP 4.4?
Rasma asked 1 year ago

Hello,
 
I have the woocommerce products slider plugin pro version for http://www.marvalus.eu. Yesterday my ISP upgraded the WordPress to 4.4. After that the website crashed, went white screen and was showing the following message:
 
Fatal error: Cannot redeclare get_term_meta() (previously declared in /home/marvalus/public_html/wp-includes/taxonomy.php:1628) in /home/marvalus/public_html/wp-content/plugins/woocommerce-products-slider/includes/wcps-functions.php on line 234
 
This was with the plugin version 2.1. Now I have upgraded to the latest 2.1.8. plugin version. However, before doing the WP upgrade to 4.4. I would like to check with you whether I should do it, or the site risks crashing again.
 
Thanks!
 
Kind regards
Rasma
 

1 Answers
Hasan Staff answered 1 year ago

Welcome to our forum Thanks for the report issue,
 
I can see the function get_term_meta() come with 4.4.0 , thats why it make conflict but should work fine older version.
https://developer.wordpress.org/reference/functions/get_term_meta/
 
Anyway we have removed the function get_term_meta() from Free & Premium latest version.
Please check our demo working fine with 4.4
http://paratheme.com/demo/woocommerce-products-slider/
 
Please let me know for more help.
Regards

Brenda replied 1 year ago

My slider isn’t working either and I received the same Fatal error issue. I did update to 1.11 and my wordpress was updated to 4.4. When it was at the older version 1.9, it gave the fatal error message. Need a fix to make it compatible with newer wordpress versions.

Brenda replied 1 year ago

Now, updated to wordpress 4.4 and slider 1.11, it doesn’t show at all. refer to site https://naughtyandnicelingerie.com

Brenda replied 1 year ago

Im using the paid plugin, not free version.

Brenda replied 1 year ago

I figured it out myself. Thank you