Post Grid – Not displaying posts from category

Q&ACategory: PluginPost Grid – Not displaying posts from category
Liam asked 1 year ago

Hi there,
I want to include the category post taxonomy and category filter at the top of the post grid however it is not returning any posts.
Using Post Grid Premium 2.06 and have selected the MixIt theme. There are posts in each category and I have tested this works in the standard Flat theme.
Site is currently being developed offline. Please let me know if you need any screenshots.
 
Thanks
Liam

1 Answers
Hasan Staff answered 1 year ago

welcome to our forum,
Can you please try “isotope” themes ? the same things you can do with “isotope” as “mixit” does.
If possible please provide me a demo admin account so i can check from here.
 
Best Regards

Liam replied 1 year ago

Hi Hassan, I can’t see an isotope theme option. Only:Post FormatsBig ThumbnailRoundedPrice TableEventMix ItLeft RightPost FormatsHave just tried all themes and none seem to resolve the issue. Site is currently being developed locally so not accessible yet sorry. Thanks Liam

Hasan Staff replied 1 year ago

Please use 2.0.7, i can see “mixit” also working fine can you please check any javascripts error on your site ? “isotope” added on 2.0.7 version, please re-install 2.0.7 regards

Hasan Staff replied 1 year ago

if you need more help please let me know, i can help you via TeamViewer, regards

Liam replied 1 year ago

Have upgraded to 2.0.7 now. Isotope shows the categories in the menu and all posts however does not filter them when clicked. Looking at the console there is a javascript error “TypeError: $(…).isotope is not a function”

Hasan Staff replied 1 year ago

Can you please send me screenshot of your console ? Thanks

Hasan Staff replied 1 year ago

This might happening if you are not using default jquery , can you please try with others themes. Thanks

Liam replied 1 year ago

Issue resolved thank you 🙂 It was the jquery version which was loaded. Have upgraded from 1.9.1 to 1.11.3 and it is now working. Thanks again

Hasan Staff replied 1 year ago

Congratulation 🙂 please let me know for more help. Regards

Liam replied 1 year ago

Hi Hasan, appears as though I jumped the gun earlier. The plugin only seems to work when I don’t load a jquery library. This means that other part of the site aren’t working. Any ideas?

Hasan Staff replied 1 year ago

Can you please send me your theme zip files ? tell me which part are not working so i can check the issue from my localhost. Thanks