Post Grid plugin – pagination redirects to first page after wordpress update 4.4.1

Q&ACategory: PluginPost Grid plugin – pagination redirects to first page after wordpress update 4.4.1
marine1 asked 11 months ago

Hello! I am using your free version of Post Grid with firmness wordpress theme. It was working fine until I updated the wordpress to newer version 4.4.1 yesterday. Now the pagination is not working. For example, you are on first page and you click “next” or “2” then it redirects to the first page only. If I write url/?page=2 then it takes me to page 2 of post grid but it doesn’t happen if we click on the pagination itself. Please help. Thank you. Mihir

1 Answers
Hasan Staff answered 11 months ago

Welcome to our forum,
 
Can you please tell me which version you are using ? is that Free or Pro ?
Please note Free version should work fine for pagination,
I have seen the issue for pagination & load more for Pro version for offset issue, please check 3.0.6 version i have already fixed and update the plguin at our new website.

Timeline Grid – Facebook Style Timeline maker for WordPress


If you already bought pro version from paratheme.com you don’t need to pay again, please go the link above and submit an order i will manually completed the order,
if you already bought from pickplugins.com you can get now by login here http://www.pickplugins.com/my-account/
 
Please let me know for more help.
 
Best Regards

marine1 replied 11 months ago

Thanks for the reply. I am using free version of Post Grid on my site. As I mentioned before it was working fine before I updated the wordpress to 4.4.1. The version of Post Grid which is presently installed is 2.0.3 and it does not show any update available for installation. Here is the link to my site: http://bit.ly/1n7YvQiPlease help me solve this issue.Thanks you again.

marine1 replied 11 months ago

Further more to my above, please check that the same is happening on your demo site also: http://www.pickplugins.com/demo/post-grid/ When you click on the page number on pagination it will keep you redirecting to the first page only.

Hasan Staff replied 11 months ago

Can you please create another demo page(Not Home page) and paste the shortcode and see whats happening , this might be the issue paged or page variable not working on home page. Regards

Hasan Staff replied 11 months ago

I can see when i set permalink settings to “Plain” its working fine, and when set to “Post name” its redirect to home page. let me solve the issue i will update plugin when done, Regards

marine1 replied 11 months ago

Hello Hasan,1. It works perfectly on other page than the home page / front page. But I need this on home page only. 2. Regarding your second reply, I have too noticed that it works properly if we set the permalink setting to “Plain” but I need it to work on “Post Name” as it is a major factor for SEO. This is a very critical issue for me and may be for other users also who might not have noticed this issue yet. As you have mentioned that you will solve this issue and update the plugin so will your update be available for free version also or will it be for paid version only? I appreciate your quick replies.Thank you.

Hasan Staff replied 11 months ago

No worries, i will update on both version. i am currently digging on this issue, please let me solved, i will definitely update as soon as possible. Regards

Hasan Staff replied 11 months ago

Hi, here is the solution i found, seem WP core bug, https://core.trac.wordpress.org/ticket/35344#comment:16 , no need to change on plugin code, you can solve by customizing wp-includes/canonical.php lines 264-270 from this of your wordpress installation , hope that solve yuor issue

marine1 replied 11 months ago

Good day, Hasan!Thanks a lot for your help. This solution worked perfectly. As suggested in your link, https://core.trac.wordpress.org/ticket/35344#comment:16, I changed the lines 264-270 in wp-includes/canonical.php and now it is working perfectly as it was before. I really appreciate your efforts and fast replies which helped me to solve this issue. Thank you again.